Firsty

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Network Outage in Zambia
Resolved·Degraded performance

Firsty users are no longer able to purchase packages to Zambia.

Fri, Jul 24, 2026, 12:46 PM
(1 month ago)
·
Affected components
Jul 3, 2026, 02:57 PM
Jul 24, 2026, 12:46 PM
Updates

Resolved

Firsty users are no longer able to purchase packages to Zambia.

Fri, Jul 24, 2026, 12:46 PM

Identified

We've identified an issue where customers are unable to connect reliably in Zambia.

Customers may experience no connection, drop-outs, or inconsistent connection.

We're working with our network provider with high priority to resolve this.

Fri, Jul 3, 2026, 02:57 PM(2 weeks earlier)