Firsty

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Partial issue activating Firsty data plans
Resolved·Partial outage

Our network provider has confirmed the partial outage is resolved. You should now be able to activate a new Free or paid package again. If you saw “We couldn’t activate your plan” earlier, please try again. If it still doesn’t work, contact support and we’ll help.

Thu, Aug 6, 2026, 06:39 AM
(1 month ago)
·
Affected components
Aug 6, 2026, 06:13 AM
06:39 AM
Updates

Resolved

Our network provider has confirmed the partial outage is resolved. You should now be able to activate a new Free or paid package again. If you saw “We couldn’t activate your plan” earlier, please try again. If it still doesn’t work, contact support and we’ll help.

Thu, Aug 6, 2026, 06:39 AM

Monitoring

The issue preventing some customers from activating a new plan looks resolved on our side. If you saw “We couldn’t activate your plan” earlier, please try again. If it still fails, contact support and we’ll help. We’re continuing to monitor.

Thu, Aug 6, 2026, 06:24 AM(14 minutes earlier)

Investigating

Some customers are seeing “We couldn’t activate your plan” when trying to start a new Free or paid package. This is due to a partial outage at one of our network providers. If you already have an active package, it should keep working. Usage updates may also be delayed. Not everyone is affected - we’re in contact with the provider and escalating.

Thu, Aug 6, 2026, 06:13 AM(11 minutes earlier)