Resolved
Customers should now be able to login successfully.
Investigating
We're aware of an issue where some customers are unable to login to Firsty using SMS or Whatsapp. Customers may see "Sorry we are a little bit busy right now, try again later." We're working to resolve the issue.