Firsty

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Some customers are unable to connect to the internet
Resolved·Partial outage

The issue has now been resolved

Wed, Sep 2, 2026, 06:12 PM
(2 weeks ago)
·
Affected components
Sep 2, 2026, 03:47 PM
06:12 PM
Updates

Resolved

The issue has now been resolved

Wed, Sep 2, 2026, 06:12 PM

Investigating

We are aware of an issue where some customers are unable to access the internet. We're working with our network partner with highest priority to resolve and hope for a short resolution.

If you notice that your phone connects to the network but doesn't have internet throughput, please contact support so that we can get you back online.

Wed, Sep 2, 2026, 03:47 PM(2 hours earlier)